Xbox Game Pass Ultimate BR is Currently Failing

Incident Report for GlobeTopper

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 02:38 EDT

Investigating

We are currently investigating an issue causing some orders of Xbox Game Pass Ultimate BR to fail. Updates will be posted here once we know more. We apologize for any inconvenience this may cause.
Posted Mar 03, 2026 - 07:10 EST
This incident affected: API and Partner Portal.