Calzedonia DE is Currently Failing

Incident Report for GlobeTopper

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 09:52 EDT

Investigating

We are currently investigating an issue causing some orders of Calzedonia DE to fail. Updates will be posted here once we know more. We apologize for any inconvenience this may cause.
Posted Mar 23, 2026 - 14:25 EDT